Mikrotik два провайдера

Written by on . Posted in Mikrotik

Как подключить еще одного провайдера на маршрутизаторе mikrotik? В данной статье не будем касаться темы распределение трафика и балансировки нагрузки по провайдерам, об это как нибудь в другой раз, а рассмотрим настройку маршрутизатора при которой можно подключаться к нашему оборудованию.


2pr-mikrotik

Опишем нашу схему:

  1. CN — Это основной провайдер и все маршруты default gw 192.168.50.1 идут через него.
  2. РТ — это наш второй провайдер. Вот его мы и будем подключать.
  3. Server. Предположим это почтовый сервер, который должен получать почту по 25 порту с наших двух провайдеров.

Создадим 2 правила согласно которому пакеты приходящие на провайдера РТ будут уходить обратно через его gw. После создания этих правил уже можно будет подключиться к маршрутизатору mikrotik с любого провайдера.

[admin@MikroTik] /ip route>
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.100.1 routing-mark=to-PT
[admin@MikroTik] /ip route rule>
add src-address=192.168.100.2 action=lookup table=to-PT

Следующие правила пробросят 25 порт TCP во внутреннюю сеть на IP 192.168.88.2 c обоих провайдеров и добавим masquerade

[admin@MikroTik] /ip firewall nat>
chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=25 protocol=tcp in-interface=ether1-CN dst-port=25

chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=25 protocol=tcp in-interface=ether2-PT dst-port=25

chain=srcnat action=masquerade src-address=192.168.88.0/24 out-interface=ether1-CN

chain=srcnat action=masquerade src-address=192.168.88.0/24 out-interface=ether2-PT

Маркируем входящие пакеты на провайдере PT и направляем ответы на его шлюз.

[admin@MikroTik] /ip firewall mangle>
chain=forward action=mark-connection new-connection-mark=to-PTc passthrough=yes in-interface=ether2-PT

chain=prerouting action=mark-routing new-routing-mark=to-PT passthrough=yes src-address=192.168.88.2 connection-mark=to-PTc

P.S.
Данная инструкция это частный случай моей настройки работы почтового сервера с двумя провайдерами через mikrotik. В этой статье не рассматривается как на маршрутизаторе выделить порт для второго провайдера. Так же не рассматриваются основы работы с правилами Firewall. Все сетевые адреса вымышленные.

Leave a comment